Longstanding annoying bug finally fixed!

lpickup

Administrator
Staff member
Joined
Aug 15, 2021
Messages
1,268
Nobody's ever mentioned this one (kind of wondering why not...) but I've fixed a longstanding bug with links to the map in the forum threads.

If you've ever tried clicking on any of the links to the map (maybe you didn't realize that's what those links were for?) in any of the forum threads, you'd find that they have been broken.

A long time ago they worked, and had a URL of the form .../map/#<some number>. Somewhere along the way I had to change my URL remapping feature for an unrelated reason, and it broke this. URL remapping is somewhat of a black art, and I wasn't having much luck fixing it, although I did kind of get it to work by using the form .../map#<some number>. But of course by then I had thousands of forum posts with the previous form. So I put it on the back burner with the hope of getting it to work using the previous format. Time passes, and no fix is ever done.

So finally I wrote some code to actually go through and fix all the forum posts to match the working format (and new posts will have the working format from the start). So now when you actually click the link to the site in a forum thread, you will actually be taken to the map so you can see the site! Hooray!
 
Thank you. I've clicked some forum links FROM the map and hadn't seen any issues yet. Wait I guess that's the opposite, you are talking about clicking links in the forum TO the map, huh.
 
Back
Top